lundi 13 octobre 2014

Amiga OS4 sous WinUAE - La situation avec la version 2.9 beta20

WinUAE 2.9beta20 : La fin des instabilités en vue

Les tutoriels d'installation réalisés précédemment sur ce blog ont été réalisés sur la beta 17 de WinUAE.

Cette version beta présentait un désagrément de taille: Des lors que l'on utilisait la combinaison alt+tab pour revenir au bureau de Windows, il y avait de très fortes chances de voir WinUAE "geler", pour parfois, au bout d'un certain temps se remettre a fonctionner, ou bien rester gelé pour toujours.

Sans utiliser ces combinaisons, après 30 à 90 minutes d'utilisation, l'OS4 émulé finissait de toutes façon par se "geler" pour toujours, tout en ayant WinUAE qui continuait à "travailler".

Les beta 18 et 19 n'ont pas franchement amélioré cette situation, si ce n'est même de l'empirer.

En date du 12 Octobre, Toni Wilen a publié la beta 20 de WinUAE 2.9 (soit à peine deux mois après la sortie de la première beta de WinUAE PPC), la situation s'est considérablement améliorée!!!!




Le point sur ce qui marche bien, et ce qui fonctionne moins bien


  • Il m'est hélas impossible de compiler le moindre helloworld.c dans Codebench
    Certes Codebench utilise tout un tas de dictionnaires (qui est sont longs à charger au lancement) et pompe la RAM, mais c'est pratique au quotidien pour l'édition du code...

    Malgré la présence d'une partition de SWAP, des son lancement, Codebench râle toutes les 30 secondes en indiquant "qu'il reste moins de 10Mo disponible et qu'il faut tout sauvegarder et fermer l'application"....En lançant un petit helloworld a compiler, Codebench "freeze" très souvent  l'OS4 lors du processus de création du fichier exécutable (mais pas toujours).
  • Le même programme compilé à la main lui compile et fonctionne normalement:
  • Il est désormais possible de basculer à volonté de Windows à OS4 dans WinUAE sans craintes de geler l'OS4. En test intensif depuis 24 heures, ceci ne semble plus poser aucun problème.
  • Une grosse session de codage/compilation de 4 heures à eu lieu (STormC5ED+make manuel), sans trop de soucis.
  • L'OS4 freeze de temps en temps, sans que beaucoup de mémoire ne soit consommée, ni trop de puissance de calcul, pour des raisons encore obscures!
  • L'économiseur d'écran en plante plus l'OS4 comme précédement
  • Les performances (CPU/RAM/Accès disques) sont quasi identiques à la beta17, voir le billet "benchmark"
Alors, utilisable ou pas?

Comme pour les précédentes remarques, l'OS4.1 est utilisable, mais sans apporter le confort d'une solution matérielle dédiée. L'émulateur est bien plus stable (encore quelques plantages, mais ceci vas mieux), l'OS4 "freeze" moins, mais ceci lui arrive encore, surtout lorsque la mémoire est saturée :
  1. soit le système de SWAP mis en place par Hypérion est très mauvais
  2. soit ma partition SWAP est trop grande pour les 128Mo de RAM de la CyberStromPPC, 
  3. soit WinUAE est encore en cause

Je pense qu'il s'agit des trois à la fois, et dans l'ordre de leur énumération....

Stay tunned!


Aucun commentaire:

Enregistrer un commentaire